Print
카테고리: [ Java ]
조회수: 4634

1. 소개

JCE란 Java Cryptography Extension의 약자이다. 그런데 JCE 사용 시에 Illegal key size or default parameters, Unsupported keysize or algorithm parameters 와 같은 오류가 발생하기도 한다. 이는 제한적인 암호화 정책 때문에 발생하는 문제인데 이를 해결하기 위하여 제한이 없는 정책 파일로 교체해야 한다.

 

2. 교체 설치

2-1. 다운로드 링크

http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html

JRE 버전에 다름에 주의하자.

2-2. 교체 작업